26 de setembro de 2009

OSPF - Frame Relay NBMA

Bom pessoal por motivos particulares não deu pra fazer a vídeo-aula do dynamips, mas, como estou devendo a vocês um modelo de uma rede OSPF sobre um Frame-Relay Multipoint, aproveitei esta noite pra configurar uma rede e mostrar a você o script e algumas informações interessantes.

Postarei scripts de configuração sobre este assunto importante.

Obs.: Todos os roteadores são Cisco 7200







SW_FR
hostname SW_FR
!
ip subnet-zero
!
frame-relay switching
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 203 interface Serial1/1 302
frame-relay route 204 interface Serial1/2 402
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 302 interface Serial1/0 203
frame-relay route 304 interface Serial1/2 403
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 402 interface Serial1/0 204
frame-relay route 403 interface Serial1/1 304



R2
hostname R2
!
no logging console
!
ip subnet-zero
!
!
!
interface Serial1/0.200 multipoint
ip address 192.168.0.2 255.255.255.0
frame-relay map ip 192.168.0.3 203 broadcast
frame-relay map ip 192.168.0.4 204 broadcast
!
interface Serial1/1
ip address 192.168.2.1 255.255.255.0
serial restart-delay 0
!

router ospf 200
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
neighbor 192.168.0.4
neighbor 192.168.0.3
!
ip classless


R2#sh ip ospf nei
R2#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.2.2 0 FULL/ - 00:00:31 192.168.2.2 Serial1/1
172.16.0.1 1 FULL/DR 00:01:47 192.168.0.4 Serial1/0.200
192.168.3.1 1 FULL/BDR 00:01:30 192.168.0.3 Serial1/0.200
R2#

Percebam que o DR é o vizinho com o ID 172.16.0.1

Repare também que ele tá pingando pra todo mundo.

R2#ping 255.255.255.255

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 255.255.255.255, timeout is 2 seconds:

Reply to request 0 from 192.168.2.2, 92 ms
Reply to request 0 from 192.168.0.4, 364 ms
Reply to request 0 from 192.168.0.3, 364 ms
Reply to request 1 from 192.168.2.2, 56 ms
Reply to request 1 from 192.168.0.3, 352 ms
Reply to request 1 from 192.168.0.4, 244 ms
Reply to request 2 from 192.168.2.2, 100 ms
Reply to request 2 from 192.168.0.3, 364 ms
Reply to request 2 from 192.168.0.4, 308 ms
Reply to request 3 from 192.168.2.2, 128 ms
Reply to request 3 from 192.168.0.4, 408 ms
Reply to request 3 from 192.168.0.3, 408 ms
Reply to request 4 from 192.168.2.2, 104 ms
Reply to request 4 from 192.168.0.4, 416 ms
Reply to request 4 from 192.168.0.3, 276 ms

Vejam a tabela de roteamento.

R2#sh ip route
Codes: C - connected, S - static, O - OSPF, IA - OSPF inter area

Gateway of last resort is not set

172.16.0.0/32 is subnetted, 1 subnets
O 172.16.0.1 [110/65] via 192.168.0.4, 00:23:53, Serial1/0.200
O192.168.4.0/24 [110/128] via 192.168.0.4, 00:23:53, Serial1/0.200
C192.168.0.0/24 is directly connected, Serial1/0.200
C192.168.2.0/24 is directly connected, Serial1/1
O192.168.3.0/24 [110/128] via 192.168.0.3, 00:23:53, Serial1/0.200



R3

hostname R3
!
no logging console
!
ip subnet-zero
!
!
!
interface Serial1/0.300 multipoint
ip address 192.168.0.3 255.255.255.0
frame-relay map ip 192.168.0.2 302 broadcast
frame-relay map ip 192.168.0.4 304 broadcast
!
interface Serial1/1
ip address 192.168.3.1 255.255.255.0
serial restart-delay 0
!
!
router ospf 300
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
neighbor 192.168.0.2
neighbor 192.168.0.4
!
ip classless



R4
hostname R4
!
ip subnet-zero
!
!
!
interface Loopback0
ip address 172.16.0.1 255.255.0.0
!
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.400 multipoint
ip address 192.168.0.4 255.255.255.0
frame-relay map ip 192.168.0.2 402 broadcast
frame-relay map ip 192.168.0.3 403 broadcast
!
interface Serial1/1
ip address 192.168.4.1 255.255.255.0
serial restart-delay 0
!
router ospf 400
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
neighbor 192.168.0.2
neighbor 192.168.0.3
!
ip classless



R5
hostname R5
!
ip subnet-zero
!
!
!
interface Serial1/0
ip address 192.168.2.2 255.255.255.0
serial restart-delay 0
!
router ospf 500
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
!
ip classless



R6

hostname R6
!
ip subnet-zero
!
interface Serial1/0
ip address 192.168.3.2 255.255.255.0
serial restart-delay 0
!
!
router ospf 600
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 0
!
ip classless




R7

hostname R7
!
!
ip subnet-zero
!
!
interface Serial1/0
ip address 192.168.4.2 255.255.255.0
serial restart-delay 0
!
!
!
router ospf 700
log-adjacency-changes
network 192.168.4.0 0.0.0.255 area 0
!
ip classless

0 comentários:

Postar um comentário

Twitter Delicious Facebook Digg Stumbleupon Favorites More